New unlock key required?

So you are planning on installing a new release of PROFESSIONAL over a pre-exsting installation that is currently working and want to know if you will need a new unlock key to get it to work.

Some things to keep in mind

  • The unlock key has embedded in it the expiration date of your current support subscription.

  • For a new version to work the expiration date of your subscription needs to be after the date of the version that you are installing. So, for example, if your subscription expires May 1, 2017 then you can install and run the 2017.0423 (April 23, 2017) version but not the 2017.0823 (August 23, 2017) version.

  • When you renew your subscription and the date of your subscription expiration changes, your HICSOAP program will try to learn this on its own by talking to our customer database over the internet. This is why after paying for support subscription, the expiration date in the upper right hand corner of the screen may change automatically.


So the the conditions where you probably will NOT need us to send you a new unlock key are

  • The computer you are using has internet access.

  • The expiration date of your support subscription as shown in the upper right hand corner of the MAIN MENU is after the date of the version you are installing.


The conditions where you will probably need us to send you a new unlock key are

  • Your current version is old and does not have a subscription expiration date listed in the upper right corner.

  • The subscription expiration date in the upper right corner of the MAIN MENU is incorrect.

  • The computer you are using does not have internet access.


Please remember that we cannot send you a new unlock key unless you send us your registration number and, of course, you need a current support subscription.

But even if you do need a new unlock key and we can't give you one immediately, there isn't a downside to installing the new version because you can always run the previous version. When you install a new version, the old version is not removed.